I created a geth console with

geth --datadir /Users/test/data/privateEthereum --networkid 42 --nodiscover --rpc --rpcport "8042" --port "30303" --maxpeers 3 --nat=any --rpccorsdomain \"*\"  --unlock "0,1" --password /Users/test/data/privateEthereum/password.txt console

and started the miner

When I started the bridge with

node bridge -H localhost:8042 -a 1

I get

Please wait...

[2017-11-03T17:22:51.822Z] INFO you are running ethereum-bridge - version: 0.5.5

[2017-11-03T17:22:51.823Z] INFO saving logs to: ./bridge.log

[2017-11-03T17:22:51.823Z] INFO using active mode

[2017-11-03T17:22:51.823Z] INFO Connecting to eth node http://localhost:8042

[2017-11-03T17:22:53.256Z] INFO connected to node type Geth/v1.7.2-stable-1db4ecdc/darwin-amd64/go1.9.2

[2017-11-03T17:22:53.885Z] WARN Using 0x974e5ce3d49bacb3d6d47b827e12972940fb764d to query contracts on your blockchain, make sure it is unlocked and do not use the same address to deploy your contracts

[2017-11-03T17:22:54.025Z] INFO deploying the oraclize connector contract...

[2017-11-03T17:23:04.410Z] INFO connector deployed to: 0x879db369b9b06260c59e7123f2d9dd650353a689

[2017-11-03T17:23:05.705Z] WARN deterministic OAR disabled/not available, please update your contract with the new custom address generated

[2017-11-03T17:23:05.706Z] INFO deploying the address resolver contract...

[2017-11-03T17:23:16.482Z] INFO address resolver (OAR) deployed to: 0xabd00b99c13644df9f0b5c2f91ea3f718615e075

[2017-11-03T17:23:16.482Z] INFO updating connector pricing...

[2017-11-03T17:23:26.730Z] INFO successfully deployed all contracts

[2017-11-03T17:23:26.735Z] INFO instance configuration file saved to /Users/test/code/blockchain/ethereum-bridge/config/instance/oracle_instance_20171103T102326.json

How do I correct this?

WARN deterministic OAR disabled/not available

There must be a mistake in my configuration. Any suggestions?

  • that's just a warning. Having you tried using OAR = OraclizeAddrResolverI(0xabd00b99c13644df9f0b5c2f91ea3f718615e075); as first line of your contract's constructor. Nov 3, 2017 at 21:00
  • It is more than a warning. My contract is not able to access the web. As you suggested, when I add the OAR statement in my contract, it works fine. However, Oraclize tells that I do not have to write that in my contract. See ethereum.stackexchange.com/questions/23301/… Nov 3, 2017 at 22:05
  • I am not very sure about the Marco's answer, have not tried that personally. I used Oraclize long ago and then there we need to include the OAR in contract's constructor. Nov 4, 2017 at 4:39
  • 1
    If we close the node-bridge, then OAR will disappear...Is that means for next time deploying the contract we have to add new OAR to contract constructor? Is there any solution for OAR address keeps same in privateNet like testnet?
    – lekshmi
    Sep 6, 2018 at 3:55

2 Answers 2


There is no wrong, it is just a warning,you just need to put your OAR address in your contract constructor. I think you may encounter some problem when using ethereum-bridge, and i have a look at your command to satrt your private network, and it's the command that causes problem.

The oraclize(ethereum-bridge) is only supported the devchain , which means you should start your private network using geth like

geth --networkid 15 --datadir ./data --rpc --rpcapi "admin,debug,eth,miner,net,personal,txpool,web3" --rpcport "8545" --rpccorsdomain "*"  --dev

or simply, you can start you your private network using

geth --dev --rpc console
  • if you deploy the contract using ethereum-bridge on Non-dev private network, you will get gas error like
gas required exceeds allowance or always failing transaction in private network

so, all the problem is caused by Non-devprivate network! Good luck for you!


I have done the same work like you, and got the OAR WARNING, the oraclize-support in the oraclize gitter said that if you use ethereum-bridge on the mainnet, OAR is not needed, but it has to be add to the constructor of your contract if it's on private chain.Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.