3

I am having a weird issue where my migrations are not being deployed when I run truffle migrate --network development. But when I run truffle migrate --network development --reset, the contracts are being deployed correctly. Does anybody know what the cause to this could be?

I am on truffle version 4.0.1 and solidity version 0.4.18.

This is an example of the console messages I am seeing. In this picture I just added the staging network to my truffle.js before running these migrate commands. (The authentication error is expected)

enter image description here

  • I have the same problem. I even tested it with the Metacoin.sol contract which is generated by truffle init. – Bumblebee Nov 7 '17 at 15:14
3

Have you previously migrated the contracts? If you ran a previous migration and didn't change any of the contracts/migration details, truffle migrate will not do anything. --reset forces it to run the entire migration from the beginning.

https://truffle.readthedocs.io/en/beta/getting_started/migrations/

$ truffle migrate

This will run all migrations located within your project's migrations directory. If your migrations were previously run successfully, truffle migrate will start execution from the last migration that was ran, running only newly created migrations. If no new migrations exists, truffle migrate won't perform any action at all. You can use the --reset option to run all your migrations from the beginning.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.