1

I am facing an issue here when I start the miner process with miner.start(1). It gives me error as below. I tried to search for the solution but could not find any. I am using Ubuntu 16.04 LTS on Intel i3 processor, 4 GB RAM and 4 GB Swap. I also tried to look for answers on this platform but didn't see any relevant solution.

    miner.start(1) 
    INFO [10-24|18:55:59] Updated mining threads threads=1 
    INFO [10-24|18:55:59] Transaction pool price threshold updated price=18000000000 
INFO [10-24|18:55:59] Starting mining operation null 
    INFO [10-24|18:55:59] Commit new mining work number=1 txs=1 uncles=0 elapsed=667.378µs 
    INFO [10-24|18:56:02] Generating ethash verification cache epoch=1 percentage=80 elapsed=3.010s 
    INFO [10-24|18:56:03] Generated ethash verification cache epoch=1 elapsed=3.687s 
    ERROR[10-24|18:56:03] Failed to generate mapped ethash dataset epoch=1 err=”cannot allocate memory” runtime: out of memory: cannot allocate 2164260864-byte block (119799808 in use) fatal error: out of memory
  • Even I had issues with miner.start(). Though you can try to start geth with --mine flag. – Kannan Ravindran Oct 24 '17 at 16:57
1

I once had a similar issue.
The problem was i was running the 32bit version on a 64bit system.
Kindly confirm that you are using the correct version for your system(32bit or 64bit).
Hope this helps.

  • Are you sure this was the problem? I am running on Ubuntu 32bit on a 64bit machine. If you say so, let me try re-installing the OS and install the ether setup again. – Parth Trivedi Oct 24 '17 at 17:12
  • 1
    It was the problem for me. I was running the 32bit Geth on a Windows 10 64bit system. I can not say for sure the same problem happens on Ubuntu, though. – Adibas03 Oct 24 '17 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.