9

I've got a little private chain running which occasionally runs some rather labour-intensive transactions.

I was able to set the initial block gas limit using the "gasLimit" parameter in genesis.json but that seems to get automatically adjusted down over time back to the public chain default.

Short of feeding the chain intentionally labour-intensive transactions every single block to keep the average up, is there anything I can do to stop it adjusting downwards?

8

If you're using Geth, the develop branch contains a --targetgaslimit flag that will instruct the miner to target a specific number instead of the hard coded default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.