I'm new to ethereum and tried to create a basic token, I deployed contract according with instruction on ethereum website but for some reason it stuck on "deploying contract" phase.

My wallet is fully synced, and transaction is confirmed about a day ago but I don't see my token on contracts page in the wallet and can't access admin page - it still says "creating contract".

enter image description here

Etherscan sees my token, but my wallet does not: https://etherscan.io/token/0x7c8a25cecf3e1d782028cb0ae7f0e23d2a87410c

Would be grateful for any suggestions of what can be wrong and what can I do to resolve this issue.

1 Answer 1


I think, that you need to add your token by clicking 'Watch token' at the bottom of "Contracts" menu. Watch token button

After you'll click this button, you'll need to paste there address of your token. It is 0x7c8a25cecf3e1d782028cb0ae7f0e23d2a87410c

Also, you need to click 'Watch Contract'

Watch contract button

Then paste there interface of your contract and address of your contract.

If you still can't see tokens, you can use wallet.ethereum.org with MetaMask extension for browser.

  • Thank you, I managed to add token, but when I click on "watch contract" it asks for something called 'json interface' - where should I get it? I followed instructions on ethereum.org/token - not a word about such thing. And I still unable to admin my token.
    – Bobres
    Oct 19, 2017 at 20:45
  • Could you show me your code? Basically, you can use Remix to get JSON-Interface, but if you don't how, just send me your code, I'll compile it :)
    – sp41mer
    Oct 20, 2017 at 0:59
  • I used remix to create json-interface and successfully added my token to Ethereum Wallet, I still can't admin it however and for some reason it shows balance in Ether instead of my token, I thought something may be wrong with my code and just copied token code from ethereum.org/token, deployed it and still got the same problems - no admin page and when I add it with "watch token" button it shows zero balance instead of 1 bil. tokens I created on start.
    – Bobres
    Oct 20, 2017 at 16:01
  • Would you like to try wallet.ethereum.org ? It seems like bug in Ethereum Wallet
    – sp41mer
    Oct 20, 2017 at 17:35
  • Nope, still not working: Unable to connect. Please start geth with the following options: geth --rpc --rpccorsdomain "wallet.ethereum.org" I guess I give up on Ethereum for now and return when it will be properly developed, but thanks for your help :)
    – Bobres
    Oct 20, 2017 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.