3

I have an Amazon EC2 instance set up running a Parity node. I'm trying to communicate with it via Web3 (using Nethereum.Web3 in C#).

If I connect locally with http://127.0.0.1:8545, everything works great.

If I try to connect from a different EC2 instance using http://somePrivateIP:8545, the RPC request fails to connect.

If I try to connect from my home PC using http://somePublicIP:8545, the RPC request also fails to connect.

I have enabled ALL traffic on TCP 8545 in the AWS security group.

I am starting Parity with everything relevant I can think of enabled:

C:\Program Files\Parity\Parity\ptray.exe --jsonrpc-apis all --jsonrpc-hosts all --jsonrpc-interface all

What am I missing?

3
  • Does it work if you enable --unsafe-expose? Edit: it's not ptray.exe but parity.exe.
    – q9f
    Commented Nov 20, 2017 at 14:03
  • Was this ever solved? Commented Apr 30, 2018 at 12:50
  • I switched to using Infura for the node in the end
    – AndyK
    Commented May 1, 2018 at 13:30

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.