0

I want to upgrade my geth node from 1.6.7 to 1.7.2. However it did not work. How can I solve it?

$ sudo apt-get install ethereum
Unpacking ethereum (1.7.2+build11187+xenial) over (1.6.7+build10273+xenial) ...
Setting up ethereum (1.7.2+build11187+xenial) ...

$ geth version
Geth
Version: 1.6.7-stable
$ which geth
/usr/bin/geth <-- geth is not changed
  • 1
    Did you try sudo apt-get upgrade ? – jojeyh Oct 18 '17 at 22:13
  • Also make sure you using the latest version of go, this might affect the download. – jojeyh Oct 18 '17 at 22:50
  • 1
    Can you check if there's an instance running? ps -ef | grep -i geth. Worst case you can restart the machine. – Ismael Oct 19 '17 at 6:53
  • @jojeyh I'm sorry for the late reply. Yes you are completely right. I just did 'sudo apt-get upgrade' then it worked. If you post it as the answer, I'll accept it. Thank you so much. – zono Oct 24 '17 at 11:50
  • How about the degrade? – Ender Nov 19 '19 at 1:52
1

Type in sudo apt-get upgrade to upgrade to the newest version of geth and you should be good to go!

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.