4

I am trying to run geth on google cloud. I finnaly managed to install it, but when running it, it's not syncyng with the blockchain (rynkeby).

INFO [10-18|10:24:28] Initialising Ethereum protocol           versions="[63 62]" network=1
INFO [10-18|10:24:28] Loaded most recent local header          number=0 hash=d4e567…cb8fa3 td=17
179869184
INFO [10-18|10:24:28] Loaded most recent local full block      number=0 hash=d4e567…cb8fa3 td=17
179869184
INFO [10-18|10:24:28] Loaded most recent local fast block      number=0 hash=d4e567…cb8fa3 td=17
179869184

Running geth --fast at beggining did not change anything.

Why is it not syncyng?

1

You need to open TCP and UDP ports 30303

1

Actually you need to open up TCP port 30303 and UDP ports 30303 and 30304.

Also, if you want to connect to it via HTTP/RPC you need to enable that when you start geth and open port 8545. That's the default, but you can change it. Or, better yet, connect via an SSH tunnel.

Regardless, for RPC access I suggest you lock down the origin IP to be only from your own and other trusted ones.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.