0

I have installed the Wallet v0.9.1 but have not been able to reach sync. It starts at good speed (1000 blocks/sec), but after 1 hour and 3.5Mblocks it slows down and I notice my 8GB RAM is taken. There is space on my SSD. OS is Windows7 Pro.

I tried removing the chaindata folder and run geth --fast --cache=2048, but it is the same story. Memory is eaten, computer slows down and finally hangs. It helps to restart the Wallet but after a minute, RAM usage grows.

I tried to sync the testnet instead, but end up in the same situation. Frustrating to be 100 blocks from sync and not getting all the way.

Is there anyone who can help me out of this? Thank's

0

You can try running the 32 bit wallet, would limit its usage RAM usage to 4GB. Perhaps this would reduce the drain on your computer's resources.

You can double check the space on you SSD and where the wallet is downloading chaindata (I know you already said that you had free space but it never hurts to double check). Also the entire chain is a huge download ~312GB if this site is correct.

Is the sync still making progress even when it slows down? Perhaps just leaving it overnight might help resolve the issue as well. Syncing the entire blockchain is no easy feat.

  • I tried the 32-bit version and geth 1.7.2 and mist wallet to 0.9.2. Same story. I checked disk space and there is 20GB free (128G SSD). Perhaps my Dell latitude E6520 (i5, 8GB) is too old for this. – pellegnillot Oct 15 '17 at 19:34
  • Well like I said, the blockchain is over 300GB, even the Ropsten Testnet is > 40, it is probably trying to allocate space but is having trouble since you are only working with 20GB free. If you have an external harddrive you can try running geth from there. You can try just running Geth from the command line and see if it runs successfully to eliminate the possibility that it is the mist client. – Fortune Oct 16 '17 at 1:00
  • Update: I hooked up a 1TB USB HDD and restarted: geth --fast --data-dir "E:\Ethereum" It has now run for two days creating a chaindata folder 29.4GB. It ran fast initially but slowing down after 3Mblocks. Currently at 4.390.828 out of 4.390.904. It is steadily lagging ~100 blocks behind. Will it ever catch up? The upside is that RAM is fine, the runaway issue is gone. – pellegnillot Oct 19 '17 at 18:16
  • 2
    Finally, I am synced! But, do I dare to send my real ether here? No. My next step will be to sync the testnet and learn about creation of contracts. Thank's fortune! – pellegnillot Oct 19 '17 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.