1

I am deploying a contract on a private blockchain using Parity. The migration seems to default to 4712388 gas (not sure why) and I get this error:

[-32010] Transaction cost exceeds current gas limit. Limit: 21127, got: 4712388. Try decreasing supplied gas.

My question is:

where does this 21127 number come from? It is not in my genesis file for the private blockchain, since 21127 in hex is 0x5287 and that number is not present.

My gasLimit=0x5280. But two things make me think this is not related. (1) 5280 is not equal to 5287. And (2) the gasLimit should only relate to the genesis block, right? (See gasLimit vs. minGasLimit)

This issue is similar to another error I get with a diffrent configuration, but since the numbers are slightly different I do not think it related. But maybe? Setting Block Gas Limit in private blockchain?

0

The question was:

where does this 21127 number come from?

The answer (provided by @benjaminion in another thread) is:

A transaction will always use at least 21000 gas since that is the value specified in the protocol: it is the quantity G_transaction in the Yellow Paper, appendix G.

  • @benjaminion You've just been cited. :) – stone.212 Nov 1 '17 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.