0

I'm following Medium tutorial and is stuck on the step where contract should be deployed. I did everything like described in the tutorial but when I run truffle migrate it displays

Using network 'development'.

Running migration: 1_initial_migration.js
  Deploying Migrations...
  ... 0x1724c314275c3449e202592c37b57eb670cec5a1fe3bff53fab36ec2f094b19f

then hangs for about 10-20 minutes and then displays

Error encountered, bailing. Network state unknown. Review successful transactions manually.
Error: Contract transaction couldn't be found after 50 blocks

I'm using geth, running node locally which is synced, have about 4 ether on my test account. As far as I understand message says that contract is not found on blockchain which makes sense: when I look up transaction with id 0x1724c314275c3449e202592c37b57eb670cec5a1fe3bff53fab36ec2f094b19f (one that is printed in console) etherscan says state is "pending". It stays in this state for 30 minutes or so and then disappears completely.

I've tried to increase the "gasPrice" to 200 Wei but that didn't help

What could be the reason of this?

Update

If you are having the same problem while going through the tutorial see my comment to resolve the issue by using "rinkeby" network.

  • Ropsten network might be under attack. However I was able to receive test ether through faucet... – yname Sep 30 '17 at 21:39
2

It would seem that ropsten is currently under attack. I've been unable to receive Ether or create contracts even with gas prices which would otherwise be insane.

  • 1
    Thanks for sharing this, Joshua. I was wondering if I did something wrong. I couldn't migrate the whole night on Ropsten. – chuacw Oct 1 '17 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.