2

This question already has an answer here:

I am using the mist wallet to deploy the standard ERC20 contract that it provides in its tutorial. in my wallet has 0.05 ether, but whenever I try to deploy the contract, even at the cheapest possible mining speed I get an error message

exceeds block gas limit

What am I doing wrong?

marked as duplicate by Ismael, Richard Horrocks, lungj, Nicolas Massart, Badr Bellaj Oct 7 '17 at 10:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Hi there. By "cheapest possible mining speed" do you mean the lowest amount of gas? What settings are you using in Mist when deploying the contract? – Richard Horrocks Sep 29 '17 at 7:46
  • On the fee slider, I set it to the cheaper side – Oscar Chambers Sep 29 '17 at 7:57
  • @OscarChambers The block gas limit is to prevent malicious attacks to the Ethereum network. If you contract is too big it will generate that error, it cannot be changed without the approval of the majority of the miners. One alternative is to 'trim' your contract, another is to split into several smaller contracts. – Ismael Sep 30 '17 at 3:59
  • You should try to minimize the gas amount that you are passing during transaction. – jatin agarwal Oct 6 '17 at 3:39
1

I believe this is related to the gaslimit set in the init genesis file - I had the same issue. I had to delete my blockchain, increase the gaslimit parameter in the genesis.json, rebuild the blockchain, etc - and then it worked no problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.