3

I recently updated cpp-ethereum. I am now on ethminer version 1.2.3

when I start it to mine with ethminer --opencl-device 1 I get the folowing output.

Getting work package...
Segmentation fault: 11

What might be wrong. before the cpp-ethereum update it worked.

10
  • maybe try gdb --args ethminer --opencl-device 1 to see if you can backtrace the error
    – euri10
    Commented Apr 5, 2016 at 12:22
  • -bash: gdb: command not found what is gdb?
    – xpnimi
    Commented Apr 5, 2016 at 12:25
  • gnu.org/software/gdb , you can install it with sudo aptitude install gdb. once in gdb you enter run, when it crashes you type backtrace. maybe this would be more appropriate to post in the reposiory though if it crashes all the time ;)
    – euri10
    Commented Apr 5, 2016 at 12:26
  • does it work on osx?
    – xpnimi
    Commented Apr 5, 2016 at 12:35
  • sorry can't comment on this, this was a linux thing
    – euri10
    Commented Apr 5, 2016 at 12:36

1 Answer 1

2

ok never mind, think I had the same issue described in issue #477 https://github.com/ethereum/solidity/issues/477#issuecomment-206313939

Resolved it by downloading https://build.ethdev.com/cpp-binaries-data/release-1.2.3/Ethereum.dmg and copying the described file: libjsoncpp.dylib from AlethOne/Contents/Frameworks/libjsoncpp.dylib to usr/local/lib/

now it works.

Not the answer you're looking for? Browse other questions tagged or ask your own question.