I've been trying to run this command evm --debug --code 600580600b6000396000f36005600401, and some associated permutations of it, such as:

evm --debug --code 366020036101000a600035045b6001900380600c57 --input 0101

However, all I ever see as a result is the help menu, i.e.

enter image description here

Has this command been deprecated, or am I doing something wrong?

  • 1
    Did you forget the run command? – Ismael Sep 17 '17 at 20:55
  • what do you mean? I've not forgotten it- because I never knew it. can you maybe- show me an example? UPDATE wait- I did try that, for this evm run --debug --code 600580600b6000396000f36005600401 I get this error Incorrect Usage: flag provided but not defined: -debug flag provided but not defined: -debug – s.matthew.english Sep 17 '17 at 21:00
  • 1
    I've tried evm --debug --code 366020036101000a600035045b6001900380600c57 --input 0101 run with evm version 1.6.7-stable-ab5646c5 and it works. – Ismael Sep 17 '17 at 21:21
  • 1
    yeah- I tried with run in the front, you need to put run in the back! anyway- thanks for your help! :D – s.matthew.english Sep 17 '17 at 21:22
up vote 3 down vote accepted

You've gotta put run in the BACK!

Like this:

evm --debug --code 6000355b6001900380600357 --input 0000000000000000000000000000000000000000000000000000000000000005 run

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.