1

I am just getting started on ethereum programming on a Mac (OS Siera 10.12.6) and am trying to set up my environment. I am following the Ethereum.org installation instructions.

I completed these steps to install geth I believe:

brew tap ethereum/ethereum
brew install ethereum

and I'm now at the geth account and console steps.

However, I get this error:

geth account new
-bash: geth: command not found

and

geth console
-bash: geth: command not found

and when I cd to the directory ./Library/Caches/Homebrew/ethereum--git/cmd/geth

and run it there I get the same error.

Also, these are the files I see in the directory and don't see one specifically for geth.

ls /Users/me/Library/Caches/Homebrew/ethereum--git/cmd/geth
accountcmd.go       genesis_test.go
accountcmd_test.go  main.go
bugcmd.go       misccmd.go
chaincmd.go     monitorcmd.go
config.go       run_test.go
consolecmd.go       testdata
consolecmd_test.go  usage.go
dao_test.go

Is there an installation step I still need to perform?

Is the documentation out of date? Are there some good, current documentation and tutorials you would recommend?

I do see this command: consolecmd.go

I'm not familiar with the go language but see quite a few files with the .go extension.

I don't think I have Go enabled because when I tried to cd to the directory it wasn't found:

cd /usr/local/go
-bash: cd: /usr/local/go: No such file or directory

Any help would be appreciated.

  • try to run brew update brew upgrade and retry the installation process – Badr Bellaj Sep 16 '17 at 16:32
1

My issue was that I didn't have /usr/local/bin included in my $PATH environment variable. The geth executable is located in this directory.

So I edited my profile: (vi .bash_profile) and added it to the beginning of my directories in it.

0

I struggled with a similar problem and the solution is to add the geth.exe path to your .bash_profile file.

Another way is to solve is to find the geth.exe file in your laptop and copy it to usr/local/bin ( Make sure that usr/local/bin is already addded in your .bash_profile)

0

you can solve this issue by adding it to your .bash_profile file

These are the steps

  1. open terminal type cd
  2. nano .bash_profile ( or ~/.bash_profile)
  3. add this line
  4. export PATH=/Users/Documents/go-ethereum/build/bin:$PATH
  5. (This is your geth.exec file path)
  6. source .bash_profile
  7. geth

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.