0

I have a problem with deploying contract on myetherwallet. It keeps showing this no mmatter what I do:

enter image description here

Any idea what is wrong or what I need to do? I tried updating syncing my node last night but some reason it was super slow and didn't even finish half.

I just want a way to easily deploy my test contracts to test net. It seems to me I am just doing something wrong here, because as a test I took a contract directly from ethereums website (the ballot one) and tried to upload it and it wont work.

EDIT: I am deploying from taking the bytecode from remix, and pasting it in metamask

  • I got it to work using Remix and deploying. The main issue was my contract was very high in gas (4.4 million), and some reason it was not working for a long time. Then when I increased gwei to 120 and made the gas limit the absolute max, around 4.7 million, it worked. Not sure if the issue was it was always short on gas by a bit, or if i needed to increase gwei a lot to get into a block that i was filling up almost by myself. However I still don't know how to deploy with metamask so if anyone can fill in thats great! – dave kajpust Sep 5 '17 at 12:44
  • Apparently, online MyEtherWallet does not support contract deployment: reddit.com/r/ethereum/comments/49dj1n/… – Ay. Oct 11 '17 at 18:31
  • You can use remix+Metamask to deploy your contract. In remix set environment to: injected web3. Then you can deploy it dirrectly from remix. In metamask state where the contract is supposed to send. – Ay. Oct 11 '17 at 18:32
  • Is the recipient address valid? – zero_cool Apr 4 '18 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.