I had setup Blockchain on Azure (BaaS) few months ago, Its working fine till few days before,

but now I am facing issue with my transaction, after debugging I found that my transactions are not getting any response from blockchain,

I checked admin portal where I found All the miners Have stopped working enter image description here

I have also checked all the VM's are running

Any one knows How to troubleshoot this issue?

2 Answers 2


I have ran into same issue more than once. Stopping all the miners and starting them again does the trick. But I do not know why this happens!

  • how to start them?? I have tried restarting the VM's dose not make any difference. Commented Oct 12, 2017 at 6:18
  • 1
    I think it should be relatively easier, there is an option to "Stop" the VM's. Stop all VM's and then choose the option "Start" on your VM's
    – Adheep
    Commented Oct 17, 2017 at 10:07
  • After restarting <or shutdown and start>, It will run for some minutes and stop working again when lastblock number of mining node and transaction node were too different.
    – Chinh Phan
    Commented Apr 12, 2018 at 2:49

I had similiar problem. And restarting the vm didn't worked.

My solution was to reimage the VM that wasn't working. But I suppose redeploying can do the trick also.

Because I just reimage one of the nodes, the ethereum network keep the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.