0

I'm running my own ethereum node on my LAN with command line:

nohup geth --rpc --rpccorsdomain "https://wallet.ethereum.org" --rpcaddr <ip> &

When running a curl command on a git bash console on my other PC it works:

$ curl -X POST --data '{"jsonrpc":"2.0","method":"web3_clientVersion","params":[],"id":67}' <ip>:8545
{"jsonrpc":"2.0","id":67,"result":"Geth/v1.6.7-stable-ab5646c5/linux-amd64/go1.8.3"}

But my issue is that https://wallet.ethereum.org/ doesn't connect to it. Have I missed something here?

2

2 Answers 2

1

If you're trying to connect to your custom node via MetaMask, like your tag suggests, you actually want to run with the flag --rpccorsdomain="chrome-extension://pgfcgpgggeefgnajgbdojefgdddlgnpi", opening your node to MetaMask, not the site you're visiting.

The site then talks to MetaMask, which intercepts, relays requests, signs transactions, and caches common responses.

4
  • Thanks for the answer, it makes sense. But I've been able to use the wallet without using the rpc cors domain you mentioned and keep --rpccorsdomain "wallet.ethereum.org". So I don't understand why it works.
    – elmattic
    Aug 27, 2017 at 1:25
  • When you load the node, you tell it what pages to accept requests from. The Ethereum wallet can talk directly to your node, and that works because the Ethereum wallet tries to connect to your node directly. Most sites should not be trusted to visit your local node, for a variety of reasons.
    – DanF
    Aug 27, 2017 at 5:36
  • One reason is that you would have to change this flag for every page, that would be inconvenient, but for most people, it's prohibitively complex. Not to mention that to send a transaction, you would have to run your node in unlocked mode, a node where it signs anything without approval.
    – DanF
    Aug 27, 2017 at 5:37
  • MetaMask provides a solution to these issues. Users who don't necessarily have a node running can connect to sites with no other setup and still get the opportunity to approve or decline any proposed transaction.
    – DanF
    Aug 27, 2017 at 5:38
0

It happens that you need to create an account on metamask to use a Custom RPC node. Once done it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.