I keep getting this error and cannot start my geth client anymore. Google searched for awhile couldn't bring me to any working solution. Do you know how to resolve this?

  • still getting issue on latest version on AWS Ec2 I have created an AWS EC2 and started working on AWS Standalone instance Jun 23, 2021 at 17:23

2 Answers 2


On some rare setups UPnP lookup fails in a strange way that blocks up Geth. It was already fixed on develop and will hopefully land soon. Until that point if you experience this you might disable NAT altogether and see if that solves the issue: --nat=none

  • 1
    Still does not work. I got this error instead (it was there with the previous nat error in fact) Read error: accept tcp [::]:30303: use of closed network connection
    – Loi.Luu
    Mar 31, 2016 at 17:07
  • 1
    Please open an issue on our bug tracker with the startup logs. It's hard to figure out the exact issue without something to look at :) Apr 1, 2016 at 8:42

I had a similar problem with my connection to Ethereum while I am on latest Geth version today 1.6.7 and tried multiple like via Mist equipped with Geth/Swarm built-in. Tried changing firewall rules and even disabled it both in Windows and on the router. No luck.

It stuck at....Mapped network port proto=tcp extport=30303 intport=30303 interface="UPNP IGDv1-IP1" ...for days without any peers to sync to blockchain.

I found the solution in my router. Even though uPnP and NAT was active it could not be discovered properly and no peers / no connections to sync. I did the following following:

  1. Logged in to the router admin
  2. Disabled NAT and uPnP and saved settings.
  3. Waited until my router came back up
  4. Enabled both uPnP and NAT back again and saved settings.

This cleared the SOAP service on my router and after this Geth started syncing again without fail. Hopefully this works for others with similar issues also.

Good luck and happy mining! :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.