2

I'm using Atom, with solidity linther package.

my local solc version is 4.15

In Atom, I cannot use anything higher than 0.4.4:

Error Solidity Source file requires different compiler version (current compiler is 0.4.4+commit.4633f3de.Emscripten.clang - note that nightly builds are considered to be strictly less than the released version

Is there a way to force it to upgrade?

  • I don't know what worked for me but I've uninstalled the atom plugin, and removed solc from the node global packages, cleared the npm cache, and reinstalled the atom plugin again, and installed solc as a global again. It appears as if the atom plugin install a copy of solc but never upgrades it, upgrading the node global copy does nothing about. – Ismael Aug 23 '17 at 3:39
  • 1
    Uninstall solidity packages, then sudo npm cache clean, then Re-install solidity packages did the trick. Thanks :) – wavekiter Aug 23 '17 at 12:23
  • Cool! Add your instruction as answer so it can help others! – Ismael Aug 23 '17 at 16:03
3

This does the trick:

  1. Uninstall solidity packages
  2. sudo npm cache clean
  3. Re-install solidity packages
  4. Re-start atom

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.