2

Question from a newbie that is learning it's way around the blockchain world. Hope you can help me out!

My Ethereum Wallet holds the main account and some accounts for testing. I also made one Wallet Contract with the main account as owner. Several months ago I transferred 1 Ether from the main account to the contract without problems.

I have tried several times to transfer the Ether back to the main contract but keep getting an "unknown account" error after providing the password and selecting Send Transaction. There is no entry in the node log so I have no idea what is happening here. Both the contract address and the main account address are filled in by the program. I have tried manual copy-paste, but with the same result.

Does it have anything to do with the status of the blockchain download? I have kept Wallet running for a whole day now, but there are still more then 400k blocks left to download.

0

The error unknown account occurs when you try to use a non-EOA account as from in sendTransaction method. For e.g.,

sendTransaction({from: contractAddtess, to: eth.accounts[0], value: web3.toWei(1, 'ether'});

This line of code will throw unknown account error, because from address is not valid EOA. The contract addresses are governed by it's code unlike EOA's which are governed by their private key. Hence to release funds from EOA you need their private key and to release funds from your contract you need to use it's code.

So your contract should have a function that transfers funds from contracts to any account.

  • Thanks for your answer. However, you're implying that I'm using code to make the transfer. This is not the case. I make use of the user interface of the Wallet to transfer the Ether. So no code involved, just selecting the two required addresses and hitting the Send button. How can I add the required function to transfer funds? This must be a really dumb question as obviously the user interface never indicated that I should add functions to a contract it made on my request. – Marc San Oct 7 '17 at 7:06
  • Okay, marc. So by UI you mean etherum-wallet, right? I tried replicating your issue at my end. Do let me know if I missed any steps. 1. I created a wallet contract (Single owner account )from Ethereum Wallet. 2. I set the owner of the wallet contract to be my main address. 3. I transferred some ethers from my main address to wallet contract. 4. I tried transferring ethers back to my main address. I didn't face any problems in this. Let me know if these were your exact steps. If yes, do let me know wallet and geth version you are using. – Prashant Prabhakar Singh Oct 7 '17 at 8:07
  • Thanks, indeed these were the exact steps I used. However there were a couple of months between generating the contract and adding the ether and again some time before trying to transferring the ether back to the main contract. I tried all the Wallet between 0.7 and 0.8.10. Geth is 1.7.2. Tonight I downloaded Ethereum Wallet 0.9.2. Same error: "unknown account" – Marc San Oct 15 '17 at 20:34
  • Just found out that if I leave the password field empty, the same error is shown "unknown account". Could it be a password issue? I use my main account password – Marc San Oct 15 '17 at 20:37
  • And some other strange behavior: I created a second test contract to replicate the issue. However this has status "creating" (and is greyed out) for months now. – Marc San Oct 15 '17 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.