3

I have a testrpc running on a machine but I want to connect the Remix IDE to it which is on another machine. I can connect to the testrpc with Remix IDE if both are on the same machine. Tried with adding "-h 0.0.0.0" parameter while initiating testrpc or same combination with machine's IP address but no success yet.

Can someone please help me on how to start testrpc server on a machine so that I can connect to it from another machine running remix IDE on the same network.

Also I tried to forward the 8545 port from the testrpc machine using ngrok and adding https ngrok address for Web3 provider in other machine's remix IDE result in success. Any way without using the ngrok as the machines are on same network and I don't want to expose the 8545 port to the world unnecessarily.

  • 1
    Can you check if you have a firewall blocking access to port 8545 from the other machine? – Ismael Aug 20 '17 at 3:25
  • 1
    Nope as I am connecting over the local network, The firewall is not a issue here, I checked the firewall and it's turned off. I can connect to any other service if I start it at the 8545 port but I think the problem is that the testrpc just allows localhost access and I don't know how it can allow access from other machine's over local network – anonR Aug 20 '17 at 3:28
0

The way I solved this problem was If it was AWS EC2 instance that is running your testrpc, find the external(public) IP of the instance Remix IDE (online) in environment (select Injected Web3 and connect to that IP). Let me know if it works for you too. I have tried this with geth but I dont' see it not working for testrpc.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.