0

My workaround used to be do a geth -removedb and start a fresh fast sync from scratch. Trying to sync with existing blockchain data instead was a lost race of catching up to the latest block.

Today even the workaround in fast sync mode (cache -1024) will not completely load the blockchain anymore. It catches up some 100-300 blocks to the latest block and stalls for hours. By the time it catches up a few hundred blocks, the latest block moved ahead again. For 4 days now. Frustrating. Any ideas?

MacMini 4GB RAM (latest MacMini doesn't support field RAM upgrade) VDSL connection with an average of 20-40Mbit throughput Geth 1.6.1 / go1.8.1 /Ethereum Wallet 0.9.0

  • Remove the entire chaindata folder and try. – niksmac Aug 14 '17 at 11:43
  • (Just commenting on this old question.) If your MacMini is running with an HDD rather than SSD, it's unlikely it'll ever catch up to the latest block... – Richard Horrocks Jan 12 '18 at 11:46
0

If you only have a few hundred remaining just check your system time. Enable network time synchronisation if you can, then restart geth. This may solve your problem.

You can try this:

sudo ntpdate -u time.apple.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.