4

I want to connect my Ledger Nano S to the Chrome Ethereum Wallet App, but it is unrecognized.

  • I setup a Ledger Nano S with Pin and Passphrase.
  • I downloaded the Chrome Bitcoin, Ethereum, and Manager apps.
  • First I opened the Chrome App Ethereum Wallet.
  • I connected the device; entered the PIN; navigated to Ethereum icon; and selected it by pushing both button simultaneously.
  • The Chrome Ethereum wallet still says, "Connect your device."

enter image description here

I read on the ledger site that the firmware needs to be up-to-date. I checked my firmware version it is 1.3.1. I opened the Ledger Manager app, and noticed that the latest version of the Ethereum app is 1.0.17. The version currently installed on the Nano S is 1.0.8.

enter image description here

I tried to install the latest version of Ethereum app on my device. I get an "Unable to install application" error.

enter image description here

So I tried to uninstall the current version by clicking the trash can icon. I get an "Unable to remove application" error.

enter image description here

FYI The Chrome Bitcoin App seems to work just fine.

enter image description here

I contacted technical support, but it says the wait could be 24-48 hours...

1

Had the same issue. Although it's counter intuitive, setting Browser support to "No" allows it to connect.

I am not sure if this is a bug or not but it does the trick

  • I think the "Browser" here refers to a web app (e.g., myetherwallet) vs. the browser-plugin app (or other desktop apps like Electrum). Not entirely sure, either. – lungj Dec 30 '17 at 19:02
0

I have previously read that restarting your computer (as simple as it sounds) may resolve this issue.

Also make sure that you do not have any other extensions or apps installed which may be interfering with the connection to the device.

0

Go to:

Settings -> Device -> Reset All

Doing this deleted my Ethereum and Bitcoin App from the device. After going through the setup process again, I opened the Ledger Manager. From the Manager I installed the Ethereum App on the device. Then I opened the Chrome Ethereum App wallet and everything worked.

enter image description here

0

Hooray! I found Solution:

  1. Start Chrome App Ethereum Wallet
  2. Unlock Ledger Nano S by PIN

    1. Ledger Nano S go to: Ethereum -> Settings
    2. Contract data -> NO
    3. Browser support -> YES
  3. ...

  4. Profit!
0

I initially set up my Ledger with a computer that had only USB 3 ports on it. When I switched to a different computer that had USB 1 or 2 ports it worked fine. On the first computer Ledger Manager worked some of the time but the Bitcoin and Ethereum apps only worked for a second and then went back to the lock screen. Try a different USB port to see if any of the ports on your computer work better than others.

0

Start Chrome App Ethereum Wallet Unlock Ledger Nano S by PIN

Ledger Nano S go to: Ethereum -> Settings

  • Contract data -> NO and YES works
  • Browser support -> NO; With YES, it does not connect to my ETH wallet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.