I have successfully deployed a new token contract on Etherscan Ropsten Network using metamask. I see my contract listed as "Unverified" so I followed the process given on https://ropsten.etherscan.io/verifyContract to get it verified but was unsuccessful with a message as follows:

CWF Verification

There are no changes done to the code. Kindly, suggest me what i'm missing here?

Other Information:

  • Contract Address: 0x0890fe640F27a74665E1Fdb5A0c532e154B7020e
  • Token Name: CWF Currency
  • Token Symbol: CWF
  • This feature compares the byte codes of the published smart contract and the one you uploaded for verification. Have you changed anything meanwhile? – Yozef Aug 10 '17 at 8:30
  • No i haven't changed anything at all! That's what amazed me. – Gagan Aug 10 '17 at 9:46
  • I also have same problem like that.but i dont know which compiler version is using in my contract. can someone help me.i will show the code.!enter image description here – nyein Sep 22 '17 at 17:34
  • Hi there. If you have a NEW question, please ask it by clicking the Ask Question button. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favorite and you will be notified of any new answers. – Richard Horrocks Sep 22 '17 at 18:39

try to verified contract with Optimization Disabled with out add ABI code

  • Where exactly is this "Optimization Disabled" setting located? Somewhere on etherscan web site? Or in metamask? – Klesun Jan 18 '20 at 18:36

If you haven't changed your source code, the only possible reason seems to be that Metamask and Etherscan use different compiler versions.

  • Yes, thank you for mentioning that. I corrected my mistake but didn't got any success until i disabled "Optimization". It's now resolved. :) – Gagan Aug 10 '17 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.