2

I am doing a university project on the functionality of the EVM. I need to use debug.traceTransaction() function which requires a fully synchronized node. I have tried to sync Geth on a university VM with the following:

geth console --cache=2048

The node is quick to synch (good internet speed, 8GB of RAM and an SSD). But each time I test it by running debug.traceTransaction() from the console, it gives me the "missing trie node" error.

I have resynched fully 4 times. There is nothing else running on the machine at the same time, so resouces should not be a problem. I am perhaps getting bad info from a nearby peer? There are a few VM's running ethereum nodes within the campus network.. could this be the problem? Is there a way to specify only nodes of a particular IP address range should be synched with?

1

After resynchronising many times, I finally got a complete state history by setting cache=1024, despite the fact the VM had 8GB of RAM, it was crashing if set at 2GB and nothing else running on machine!

0

It does not look like you are running Geth with the appropriate APIs enabled. This is outlined here.

geth --cache=2048 --rpc --rpcapi "eth,net,web3,debug" console

  • Apologies, I am syncing without those flags, but when synched adding those flags. – Gawnie Aug 8 '17 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.