I'm trying to start a geth node to connect to the Rinkeby test network by running

geth --networkid=4 --datadir=$HOME/.rinkeby --verbosity 0 --syncmode=light 
--bootnodes=enode://a24ac7c5484ef4ed0c5eb2d36620ba4ea13b8c84684e1b4aab0cebea2ae45cb4d375b77eab56516d34bfbd3c1a833fc51296ff084b770b94fb9028c4d25ccf@ --rpc 
--rpccorsdomain "*" --rpcapi=eth,web3,net,personal,ssh,db,debug --unlock="0xf905463ebd62121b16e0076cadc19a7b0e706c77" console

which has always worked fine (btw I'm aware of security concerns with the command but I don't really care about that for now). However, despite starting still, if I run


I get back an error

Error: missing trie node 60c376cdb14aec29386df043d081afcfa38a97da22e25d344c4104fd91cf6cc1 (path )
    at web3.js:3104:20
    at web3.js:6191:15
    at web3.js:5004:36
    at <anonymous>:1:1

This answer suggests removing the blockchain for a similar issue, but I'd like to avoid that since it took a while to download it the first time around. Any ideas how to solve this and why this started happening?

  • Maybe this answer could be useful for you. That error could mean data corruption, that's why it is suggested to delete the chain data. May 26 '19 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.