9

Under the Status Tab on Parity, I can see under Node Health that "Chain Synchronized" and "Connected Peers" are working fine.

However, under "Time Synchronized", I get the message: "Unable to reach time API: NTP error: NTP server is not provided.. Make sure that your clock is synchronized."

Any idea how I can get the clock synchronized, and what it means now that it's not synchronized?

Thank you!

  • Would help if you state your operating system :) – Waqar Lim Aug 3 '17 at 12:05
  • 1
    When parity says your clock is not synchronized, it means that, for example, your clock says it's 3:15:22am and everyone else's says it's closer to 3:15:51am. – lungj Aug 3 '17 at 13:16
  • Hi @5chdn! My operating system is Windows 10 Pro 64-bit. Thanks for your help! @lungj Thanks for the info. Any idea how I can resolve this? – Darien Tan Aug 5 '17 at 2:48
  • 1
    I am using win7 and have the same problem. I tried to change the clock-server but the issue persists. Is it possible, that it has something to do with me being in central europe and not elswhere? Thanks in advance! – Sankara Aug 5 '17 at 14:41
  • Sorry... just realized this is a different message. Anyway, posting an answer below. – lungj Aug 5 '17 at 15:14
4

The source code at https://github.com/paritytech/parity/blob/master/dapps/src/api/api.rs indicates that this error message means Parity was unable to find out what time your computer's time is, relative to the network. This message does not mean that your clock is set incorrectly or requires synchronization. It is an error, but it's not fatal. As long as your clock's time is set correctly, you shouldn't have any problems related to this message and you can safely ignore the message.

If your clock is off, you can synchronize it. In Windows, you can force-synchronize your clock by going to the time-changing panel for your computer. Then, disable and re-enable the option to automatically synchronize/set your clock. Windows does not automatically synchronize your clock particularly frequently by default. You can change the frequency of synchronization using these instructions if your computer's clock is not very accurate or just to be on the safe side.

  • 2
    My desktop is in a Windows Active Directory Domain, and my desktop's clock is synchronized with the domain controller's clock, which in turn is generally accurate (within 10 seconds of the UTC clock on time.is/UTC ) - yet Parity keeps on giving me these NTP warnings. I wish it could be more specific. Does Ethereum run its own version of NTP? If my clock is wrong or drifting too much why doesn't Parity tell me that instead? – Dai Aug 17 '17 at 18:16
0

The time sync is measured in milliseconds, so 10 seconds is way off. I've notice parity will stop if the time sync starts to reach 4000ms. So update the systems clock with a internet time server and those errors will stop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.