2

I've deployed my contract with a UI to Ropsten via truffle and ran npm run build and npm run dev to start the server. As soon as I launch localhost (with the account in MetaMask selected) in the browser, I get the following error in the browser console.

GET http://localhost:8080/app.js net::ERR_CONTENT_LENGTH_MISMATCH

The static content shows up, but my dApp can't show the balance in the account and perform functions.

It's happened in the past, but it would go away after a few refreshes. Now it's happening every time and I can't get my dApp to run as expected. Everything was tested and worked with testrpc. Could this be a chrome extension interfering? I tried commenting out all my HTML code and still got the same error.

1

Looks like the AdBlock chrome extension was the issue. Disabled it on my localhost and stopped getting the ERR_CONTENT_LENGTH_MISMATCH error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.