1

I'm trying to deploy a contract to the Ropsten testnet using Truffle. Already tested on testrpc, worked smoothly. I keep getting the error "Exceeds block gas limit" when I try to deploy to testnet. Even when I am not specifying any gas amounts anywhere, I always get the same error.

I noticed the following warning in the geth client, which might be affecting my network, since it seems like I'm unable to mine blocks and get ether like before.

WARN [07-27|12:26:21] System clock seems off by 20.321575601s, which can prevent network connectivity 
WARN [07-27|12:26:21] Please enable network time synchronisation in system settings.

I'm running macOS 10.12.5 and followed the instructions here a while ago, but it clearly didn't resolve my issue. Other people who get time synchronization errors seem to be on Windows. How do I fix this on a mac?

1

Found the way to sync time on my mac. Instructions here: http://osxdaily.com/2012/07/04/set-system-time-mac-os-x-command-line/

Basically ran the following in my command line:

sudo ntpdate -u time.apple.com

I was able to proceed after doing this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.