According to this information, I should be able to attach to geth with the following command on my OSX machine:

geth attach ipc://somePath/geth.ipc

in consideration of what to do about that "somePath", I attempted to follow the advice here, and use:


However, when I run the command:

 geth attach ipc:~/Library/Ethereum/geth.ipc

I get the following error message:

Fatal: Unable to attach to remote geth: dial unix ~/Library/Ethereum/geth.ipc: connect: no such file or directory

Also tried

geth attach --ipcdisable 

which resulted in this:

enter image description here

Ultimately what I'd like to do is connect to the geth console without it spewing out a bunch of text so that I can examine the account balance of my address for my testnet mining, like I was asking about here.

Any ideas about what's wrong with my geth.ipc or how I can check that address would be greatly appreciated.

2 Answers 2


got it :D

need to start with geth --verbosity 0 console --port "35555", as I've done here:

enter image description here

seems to be something particular to OSX


or you can do it like this:

geth attach ipc:/Users/s.matthew.english/Library/Ethereum/testnet/geth.ipc 

the geth.ipc file location is displayed like this:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.