1

I am using the same logic for adding peers but admin.peers is just showing [] on GETH console. I have already make sure that I am connecting via same --networkid.

The command I am using is admin.addPeer("enode://e3c8b88a63e175e612bdc7258ba47290be643132a713cef8b1cfadab14466ee75d14b4a4b4309d41675b1ce2f65483af6b1c35ea32ed088aaa093675e1de131d@10.130.5.69:30304")

where 10.130.5.69 is the IP of the machine where another node is running followed by the port num.

I have checked by adding it on the local system, it is working with the same IP but not when I am trying on different systems. Am I missing some details?

1

If it is working when both the nodes are on one machine, but not when they are on different machines then probably it is to do with your firewall settings on the second machine.

Try to telnet using telnet 10.130.5.169 30304. If you see a message like 'telnet: Unable to connect to remote host: Connection refused' then please check your firewall allows incoming connections on port 30304.

0

In my case, I was using the two different genesis.json to initialize the nodes. So key points are:

  1. use the same genesis.json

  2. two nodes should be connected to same --networkid parameter.

and rest things as it is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.