0

For some reason it froze. Midway through the syncronization I stopped and re-entered geth rpc --fast Now for some reason it's super slow! At this rate it will be done in maybe a couple years or so. (On block 4055210)

0

Check out this Pull Request on GitHub. geth --fast only works for the first sync.

To avoid opening up nodes to this extra attacker ability, fast sync (beside being solely opt-in) will only ever run during an initial sync (i.e. when the node's own blockchain is empty). After a node managed to successfully sync with the network, fast sync is forever disabled. This way anybody can quickly catch up with the network, but after the node caught up, the extra attack vector is plugged in. This feature permits users to safely use the fast sync flag (--fast), without having to worry about potential state root attacks happening to them in the future. As an additional safety feature, if a fast sync fails close to or after the random pivot point, fast sync is disabled as a safety precaution and the node reverts to full, block-processing based synchronization.

Just give it a fast connection, some processing power and a bit more time. It will be done in a couple days at most even without --fast.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.