I'm trying to run a private ethereum testnet for myself. I have installed geth 1.6.7 from the official Ubuntu PPA, and downloaded the latest Mist release from its github repo.

I've run

geth --datadir="~/mydir" init my-gen.json
geth --datadir="~/mydir" --networkid 15 --rpc console

then, on another terminal:

mist --rpc "/mydir" --mode geth --gethpath "/usr/bin/geth"

but mist doesn't connect to the running geth console (I've also tried running geth without the console). it doesn't even find geth, so it tries to download it.

basically all the posts/issues I read were solved by adjusting the rpc/ipc path, but mine seems to be correct, as per geth's output:

IPC endpoint opened: /mydir/geth.ipc

Mist's log (excerpt):

[INFO] ClientBinaryManager - Initializing...
[INFO] ClientBinaryManager - Resolving path to Eth client binary ...
[INFO] ClientBinaryManager - Eth client binary path: /opt/Mist/nodes/eth/linux-x64/eth
[INFO] ClientBinaryManager - Checking for new client binaries config from: https://raw.githubusercontent.com/ethereum/mist/master/clientBinaries.json
[INFO] ClientBinaryManager - Initializing...
[INFO] ClientBinaryManager - Resolving platform...
[INFO] ClientBinaryManager - Calculating possible clients...
[INFO] ClientBinaryManager - 1 possible clients.
[INFO] ClientBinaryManager - Verifying status of all 1 possible clients...
[INFO] ClientBinaryManager - Verify Geth status ...
[ERROR] ClientBinaryManager - Unable to resolve Geth executable: usr/bin/geth

how can I have Mist recognize the running geth instance?

  • I think Mist automatically identify your private net and geth instance. Try to run mist without parameters.
    – Lam
    Commented Jul 22, 2017 at 10:30
  • ti should, but for some reason it can't even find geth... running without parameters didn't work. Commented Jul 23, 2017 at 18:56

2 Answers 2


Try this:

geth --ipcpath eth-test-chain/geth.ipc --datadir eth-test-chain --networkid 15

it worked for me. I guess the --rpc option is interfering with the IPC interface.

Or if you need to get access to console, from another terminal issue:

geth --ipcpath eth-test-chain/geth.ipc --datadir eth-test-chain --networkid 15 console
  • it didn't work.. Commented Jul 23, 2017 at 18:58
  • Try deleting your eth-test-chain directory and starting fresh. You may want to init it with a genesis block to make sure the difficulty is low enough so that you can mine.
    – fccoelho
    Commented Jul 25, 2017 at 10:34

Create the private network : This command run

geth --networkid 20 --port 60303 --datadir "D:\Database\final_chain_database" console

and network check


enter image description here

Please try it.

Thanks you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.