0

http://remix.ethereum.org Remix Solidity Compiler does not work, solidity compiler does not show up. I guess there is heavy load on the web-page of remix so browser could not handle it and freezes.

It was working yesterday but it does not today. Does anyone face with the similar issue?

enter image description here

=> What is the recommended browser and its version to open remix?

Thank you for your valuable time and help.

  • It's working for me. Link gets automatically forwarded to "remix.ethereum.org/#version=soljson-v0.4.13+commit.fb4cb1a.js". Drop-down menu is also working. – Richard Horrocks Jul 20 '17 at 13:11
  • which browser do you use? I was using safari that s why I guess it was not working. @RichardHorrocks – alper Jul 21 '17 at 7:31
  • Chrome (actually Chromium), with uBlock and PrivacyBadger turned on. (Don't think it's the most recent version of Chromium though...) – Richard Horrocks Jul 21 '17 at 7:33
  • When I tried firefox and chrome the problem is solved on my case. I guess safari is not good to use remix, @RichardHorrocks – alper Jul 21 '17 at 7:41
  • 1
    Can it be related to a load on the web server ? I think there was a new version. Two days ago, I tried it on Chrome, it did not work. Then, immediately, I tried it on Firefox and it worked. But today, it does NOT work on Firefox also. Therefore, I am getting suspicious that maybe a lot of people are trying to use it and web server may have excessive load problem. – user813 Jul 21 '17 at 9:30
-1

Clearing site data in Chrome DevTools->Application->Clear storage solved it for a similar problem of the Solidity compiler not loading for me.

NOTE: Any earlier contract code saved in the editor files will be lost, so please take back-up of any previous source code first before clearing site data.

Now I am able to load the current 0.4.21 version and the compiler version drop-down is populated as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.