1

I am a newbie with blockchain overall. What I am trying an an experimental basis is: having a webpage display my balance in one of my accounts (on test-net).

I am using meteor for my web interface, web3 for connecting with client, client being go-ethereum. And I have geth installed on OSX as well. Problem is I can either run Ethereum Wallet or geth at one time. I understand that if the purpose is syncing with respect to chain, there is no point running two instances - wallet and geth together.

The issue is when I am trying to do some web development. I would be creating contracts etc. on JS and I would be pushing those on blockchain. (Note: everything till now is on testnet)

At the same time, I also want to do experiments on contracts using Ethereum wallet because of it's easy UI.

Question then is how to have geth and Ethereum running at the same time. Currently, when I have one running and I am trying to run another, the error is:

enter image description here

OR

if Wallet is running, same kind of resource temporarily unavailable error pops up, when I am trying to run geth using

[~]$ geth --testnet --mine --rpc --rpccorsdomain "http://localhost:3000"

What am I doing wrong?

1

if there is no ethereum node up and running, Ethereum Wallet runs its own. But if you already started a node, ethereum wallet should attach to it. The ethereum wallet use only system default ipc and if your geth use another ipc, probably ethereum wallet could not attached to it.

You can try followings:

Start node with default ipc:

geth --testnet

Start node with default ipc(especially point where default geth.ipc):

geth --testnet --ipcpath /Users/{user-name}/Library/Ethereum/geth.ipc

Instead of testnet, try to start a private network and attach to it.

geth --datadir=./chaindata --networkid 15 --ipcpath /Users/{user-name}/Library/Ethereum/geth.ipc
  • Thanks :) Tried the first two, didn't work, same error. Resource unavailable. I am not sure what we are doing in the third one, and how to effect that? – Manganese Jul 16 '17 at 16:18
  • Yes, it worked. Apparently, you don't need to add in the --ipcpath. It takes that directly from path itself. 'geth --testnet /Users/{user-name}/Library/Ethereum/testnet/geth.ipc' worked. – Manganese Jul 22 '17 at 7:53
  • adding the --ipcpath flag on launch was the fic for me thanks – JJacquet Jun 15 '18 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.