When I try to install geth to my Windows 10 pc, I have faced two problem.

first, Although my computer has intel cpu, geth Windows executable is for amd architecture. I could not find any executable for intel. The name of the exectable is: geth-windows-amd64-1.6.7-ab5646c5.exe

Second, I have tried to install geth with the previous executable, but it shows below given warning. Afterward, altough it seems installation completed successfully. geth command could not be found when I type on cmd. You can find related screenshots below.

enter image description here

enter image description here

enter image description here

  • 1
    Do not worry amd64 executables should run without problems in intel processors. The more neutral name is x86_64, but intel calls it em64t and amd amd64, they are all the same from a user perspective.
    – Ismael
    Commented Jul 16, 2017 at 16:29
  • i have also added my path variable in environmental variables and tried to execute geth command on my cmd but it still isn't working.
    – Ayush
    Commented Sep 21, 2019 at 6:16

2 Answers 2


Try and go directly to your geth path and execute it from there. Looks like it's in C:\Program Files\Geth

  • Yes, you are right :) I have add "C:\Program Files\Geth" to Path in environment variables. And restart command prompts. it works. thanks.
    – karfkars
    Commented Jul 16, 2017 at 16:51

You will have to add the Geth path to the environment variables.

You can do this by going to Control Panel>System>Advanced System Settings>Environment Variables>Path and add the path of Geth (C:\Program Files\Geth).

Restart the Command Prompt and it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.