1

So I started using geth with --fast and it is still syncing (after more then 12 hours). Is there a way to make it happen faster?

I have tried light before, the same happened but it stopped it after 6 hours.

Regards

NB: I have a 2 Mbps internet.

3

FYI: --fast is default if you start geth the first time with no blocks downloaded. If you restart geth after initial start, --fast doesn't work anymore (it only works starting from scratch).

If you have an SSD, it's expected to take 3-6h. If you have a spinning HDD, it might take days (so i wouldn't recommend it).

Try adding --cache 2048 or --cache 4096 if you have a lot of RAM (8/16GB) to help the sync a little bit (default is 1024).

  • Is there a way to start from scratch. I hsve an SSD and 8gb RAM. – echo_salik Jul 15 '17 at 8:41
  • either delete the chaindata directory or run "geth removedb" I have 8GB also and use --cache 2048. – xgabrielx Jul 15 '17 at 8:55
  • Btw if i make a temp drive in ram will it be better? I have 2mbps internet ? – echo_salik Jul 15 '17 at 9:06
  • I don't believe it will. adding the cache option will make use of the RAM. – xgabrielx Jul 15 '17 at 9:42
  • np, consider accepting my answer – xgabrielx Jul 15 '17 at 9:47
0

I highly HIGHLY doubt that the spinning disk is the bottleneck at this point in time. I've been working getting the blockchain for several weeks and the hard drive just doesn't reach saturation as shown in task manager. I will admit that some later stage of geth might be more hardware I/O speed dependent, but when I got to the deduplication stage of geth it wasn't pegging either a cpu core or the disk.

  • I gave up downloading the blockchain as I have limited download and speeds of around (not more than) 2 mbps. That slowed my house's internet, which is kinda obvious. – echo_salik Sep 6 '17 at 3:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.