1

I have read this question but it didn't solve my problem.

I'm trying to connect the Remix IDE to a running node on my computer. The node is running without issues, it's connected to the Rinkeby network and to a Dapp I'm creating. For completeness, I'm starting the node with

geth --networkid=4 --datadir=$HOME/.rinkeby --verbosity 0 --syncmode=light --bootnodes=enode://a24ac7c5484ef4ed0c5eb2d36620ba4e4aa13b8c84684e1b4aab0cebea2ae45cb4d375b77eab56516d34bfbd3c1a833fc51296ff084b770b94fb9028c4d25ccf@52.169.42.101:30303?discport=30304 --rpc --rpccorsdomain "https://remix.ethereum.org" --rpcapi=eth,web3,net,personal,ssh,db,debug console

However, when I do Contract > Environment > Web3 provider > 127.0.0.1:8545 (or localhost:8545 have tried both) the accounts that appear are not the same as the ones I get on my running geth console by typing eth.accounts. I don't know where the accounts that show up in Remix after connecting to 127.0.0.1:8545 are coming from actually.

  • try the wild card --rpccorsdomain "*" – Bobbins Jul 27 '17 at 18:46
  • Just tried that but it didn't work either. – mcansado Jul 27 '17 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.