I get this error when I run the geth upgradedb command:

I0317 08:29:57.792433    4202 chaincmd.go:137] Upgrading blockchain database
I0317 08:29:57.792491    4202 database.go:71] Alloted 16MB cache to /home/'my_user_name'/.ethereum/chaindata
Fatal: Could not open database: resource temporarily unavailable

Though the first time I run the geth --console command, my machine synced with the Ethereum Blockchain.

What Im I missing?

  • Why do you want to run upgradedb in first place? This error looks like another geth instance is already running.
    – q9f
    Mar 17, 2016 at 12:54
  • I was trying to see if I had the blockchain on my machine. Thanks though it was because another instance of geth was running.
    – Kizito
    Mar 17, 2016 at 13:07

2 Answers 2


Your geth client is already running in the background. You can attach to it by typing:

$ geth attach

in your command line. This will allow you to run commands on the geth client console.

  • For any of those wondering why this may be the case - if you have your ETH wallet application open (Mist, Ethereum Wallet, etc.), then that is your node on the network, so if you have Ethereum and geth installed on your computer, that terminal (or command line) window is simply connecting to this existing node May 24, 2017 at 3:40

In my case, since the Ethereum Wallet is running already so close the Ethereum Wallet then call geth console again it will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.