7

I'm new to mining Ethereum, and I had a question about the efficiency/throughput of my card, a 270X. I ran the benchmark utility with ethminer, which gives me a result of 18153621 H/s (18 MH/s?), however, when I run ethminer solo with geth, or in a pool, my hash rate in the console is typically reported like: "1319793 H/s = 2097152 hashes / 1.589 s", which I guess is 1.3MH/s.

What can I do to reproduce a number near the result that I was obtaining on the benchmark instead of this much lower result? With ethminer running, my GPU is 90% usage, so I guess it's utilizing as much as necessary. Do I need to recreate my DAG file? I've tried adding the openCL switch to ethminer on start, but that didn't help out either.

  • 1
    Having exactly same issue. – Eugene Bujak Mar 24 '16 at 19:50
  • you're likely mining on your CPU and not your GPU, what command you enter ? – euri10 Mar 29 '16 at 13:03
  • Same issue for me. I'm benchmarking around 17MH but mining at about 4MH. Obviously it is using the GPU, but well below the benchmarked rate. Would love to see if someone's found the solution for this. – Dan Jun 18 '16 at 5:20
  • Older question but for others: It has to do with difficulty/epochs of a given blockchain (Ether in this case). Have you updated to AMD blockchain driver and over-clocked? If so, there isn't much you can do. You could also try a lower block-height ("newer") ethash coin.. for a better hashrate. – bshea Mar 29 '18 at 13:23
2

You do mention that you have specified the opencl switch at start.

Did you specify -G in the ethminer parameters? This is required for ethminer to mine using your GPU. Here's the relevant ethminer --help :

Mining configuration:
-C,--cpu  When mining, use the CPU.
-G,--opencl  When mining use the GPU via OpenCL.
--opencl-platform <n>  When mining using -G/--opencl use OpenCL platform n (default: 0).
--opencl-device <n>  When mining using -G/--opencl use OpenCL device n (default: 0).
-t, --mining-threads <n> Limit number of CPU/GPU miners to n (default: use everything available on selected platform)
--allow-opencl-cpu Allows CPU to be considered as an OpenCL device if the OpenCL platform supports it.

You will get about 15 lines of messages that OpenCL is initialising if the switch works correctly - the same messages should be displayed when you are running the benchmark. Here's what it looks like:

[OPENCL]:Found suitable OpenCL device [Hawaii] with 8513388544 bytes of GPU memory
[OPENCL]:Using platform: AMD Accelerated Parallel Processing
[OPENCL]:Using device: Hawaii(OpenCL 2.0 AMD-APP (1800.11))
[OPENCL]:Printing program log
[OPENCL]:
[OPENCL]:Creating one big buffer for the DAG
[OPENCL]:Loading single big chunk kernels
[OPENCL]:Mapping one big chunk.
[OPENCL]:Creating buffer for header.
[OPENCL]:Creating mining buffer 0
[OPENCL]:Creating mining buffer 1
[OPENCL]:Printing program log
[OPENCL]:
[OPENCL]:Creating one big buffer for the DAG
[OPENCL]:Loading single big chunk kernels
2

This happened to me and here's what I did to fix it.

I'm on Windows 10 and was using NVIDIA CUDA 7.5. I was benchmarking at 17MH and mining at 5MH.

By Downgrading to CUDA 7.0 I starting mining at 20MH. Note that I originally installed 7.0 but I believe an NVIDIA's autoupdate updated me to 7.5. So even if you have 7.0 installed, try reinstalling it.

Best of luck and happy mining!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.