5

Previously, according to tutorials, remix IDE had cube icon to connect to geth on localhost. Now the icon is gone and its not clear if the function is still there. Is it possible? How? I take remix here: https://github.com/ethereum/browser-solidity/blob/gh-pages/remix-7daae65.zip

enter image description here

3

This functionality has now been moved to Run -> Environment -> Web3 Provider:

enter image description here

In the popup I had to enter http://127.0.0.1:8545, it did not work with the default http://localhost:8545. I am connecting to a local geth node on macOS. Make sure to enable RPC and give access to remix via:

geth --rpc --rpccorsdomain "https://remix.ethereum.org" console
  • Yes, and I get known JSON "" error. – Stepan Yakovenko Jul 11 '17 at 11:18
  • 1
    What OS are you on and which version of geth are you using? Then pls double-check that you 1) started geth with the correct parameters as I indicated, 2) entered the right address of your node in the popup of remix (try also the default http://localhost:8545). – Validity Labs - Sebastian Jul 11 '17 at 11:30
  • Here is screenshot of my problem: github.com/ethereum/browser-solidity/issues/620, can't post another answer here, not enough carma :( – Stepan Yakovenko Jul 11 '17 at 23:16
  • 1
    the reason was missing --rpc flag – Stepan Yakovenko Jul 12 '17 at 18:20
  • 1
    Yeah but that's written in my answer, just had to copy-paste that ;-) happy that it's working for you! – Validity Labs - Sebastian Jul 13 '17 at 6:53
0

Just trying to improve Sebastian's answer -- the location of this setting has changed to:

  • RunEnvironmentWeb3 Provider
    (at top right)

Web3 Provider

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.