4

I have run geth --fast --cache=1024 for a week and I think I am almost complete: etherscan.io shows:

LAST BLOCK 4005552

and my eth.syncing shows:

{
  currentBlock: 4005449,
  highestBlock: 4005553,
  knownStates: 1157252,
  pulledStates: 1141319,
  startingBlock: 4005266
}

But geth --fast never change to normal and keep on getting new state only:

INFO [07-11|09:20:49] Imported new state entries count=3 flushed=4 elapsed=0s processed=1273621 pending=10500 retry=2 duplicate=1200 unexpected=2461

What should I do? Can I just stop and run normal geth without --fast flag? Or can I try mining already?

  • To my understanding the fast flag only counts when you start syncing. Once there's data in the geth folder the flag is ignored. – webjunkie Jul 11 '17 at 21:41
  • In my understanding, as long as it does not download any block (which --fast do) then it can continue to download in fast mode, but after a block is downloaded it will be disabled. The docs said that after geth --fast download the header near the highest block then it will change to normal geth and start downloading block normally (disabled fast automatically). This event is the one that never happened with mine – adhicl Jul 14 '17 at 2:28
1

I wrote a tiny python script to overview the process. It's here https://github.com/hayorov/ethereum-sync-mertics

My output:

2019-05-06 01:00:32 avg: 1827 max: 1938 min: 1378 states/s  remain: 136604075 states     4 peers    eta@ 20:46:28.165828
2019-05-06 01:00:37 avg: 1864 max: 1938 min: 1378 states/s  remain: 136595500 states     3 peers    eta@ 20:21:14.951050
2019-05-06 01:00:42 avg: 1791 max: 1938 min: 1378 states/s  remain: 136583359 states     3 peers    eta@ 21:11:16.481006
2019-05-06 01:00:48 avg: 1742 max: 1938 min: 1378 states/s  remain: 136580287 states     3 peers    eta@ 21:46:35.797305
2019-05-06 01:00:53 avg: 1721 max: 1938 min: 1378 states/s  remain: 136575694 states     3 peers    eta@ 22:03:01.154434
2019-05-06 01:00:58 avg: 1682 max: 1938 min: 1378 states/s  remain: 136569043 states     4 peers    eta@ 22:33:15.402442
2019-05-06 01:01:03 avg: 1698 max: 1938 min: 1378 states/s  remain: 136564293 states     3 peers    eta@ 22:20:27.458747
0

I had exactly such problem and finally found that source of problem is my system time! I simply solved the problem with enabling network time synchronization on my ubuntu with following command, and then restarting geth.

timedatectl set-ntp true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.