1

I'm trying to mine using Geth. Right now, it's syncing and showing:

{
  currentBlock: 3999975,
  highestBlock: 4000109,
  knownStates: 16329,
  pulledStates: 1739,
  startingBlock: 3999975
}

The Geth console just keeps saying Imported new state entries count=384 flushed=0 elapsed=1m51.659s processed=2507 pending=20431 duplicate=0 unexpected=227. The processed number keeps going up, and the pending number goes up and down. Elapsed varies between 500ms and a few minutes.

I tried leaving it for a few hours, restarting it, using --syncmode=fast, but nothing seems to work, and it's still stuck at block 3999975/4000109...

What should I do?

Edit: I restarted Geth and it increased to 4000079/4000288 within a few seconds. Restarting it again got it to 4000210/4000298, and no progress seems to happen after the "Importing new state entries" start appearing. It's now stuck at 4000210.

  • Please see if some of the answers from this question ethereum.stackexchange.com/questions/603/… apply to your case. – Ismael Jul 9 '17 at 23:26
  • If you already started --syncmode "fast" the previous time, it should work. However if you synced even for a few seconds without it, it will - as far as I've understood - use regular speed. – Kebman Aug 17 '17 at 23:31
1

I had exactly such problem and finally found that source of problem is my system time! I simply solved the problem with enabling network time synchronization on my ubuntu with following command, and then restating geth.

timedatectl set-ntp true

0

This is normal, you need to wait until the state tries download is finished. Basically, this is how geth works and what you can do is the following:

  • Make sure you have at least 4GB of RAM.
  • You must use SSD, HDD won't work.
  • Try to add better peers manually.
-1

You need to delete the chaindata folder and re-sync, as it's corrupted, most likely. This is in ~/.ethereum on Linux. If you use syncmode=fast, you'll have to delete the lightchaindata instead. These are where the blockchain is stored. You will have to re-sync from the beginning.

However, are you sure it's "stuck"? If you connect to the node locally, is it working? Are you caught up? Can you see recent transfers in your wallet? If you make a new one, does it appear?

  • It's not completely stuck. If I leave it on "Imported new state entries" for a while, and then restart Geth, the currentBlock increases by a few hundred (but is always about 150 blocks away from the highestBlock) within a few seconds, and then goes back to "Imported new state entries". – user13950 Jul 9 '17 at 23:48
  • Right now it's at currentBlock: 4000401, highestBlock: 4000599. – user13950 Jul 9 '17 at 23:50
  • What happens if you send a transaction on your local node, does it process it and catch you up to the current block, and you're able to see it in a local wallet hitting that node? I think it's probably running OK... – diabetesjones Jul 9 '17 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.