1

This question already has an answer here:

I downloaded Geth 1.6.6 and ran it to sync the blockchain. It's been 24 hours, the chaindata folder is 12.4gb and it's still going. When should I expect it to be done? Is this normal (the website that I reading from said it would take "from 20 minutes to several hours") or have I done something wrong? I used the command geth --rpc --fast --cache=1024, if that helps. Fairly new to this, so not 100% sure what's happening.

marked as duplicate by Richard Horrocks, flygoing, Achala Dissanayake, Ismael, Roman Frolov Jan 31 '18 at 15:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Similar info here: ethereum.stackexchange.com/questions/18709/… – pebwindkraft Jul 8 '17 at 6:16
  • This is a repeating pattern, but there is no "official" statement yet as to the root cause. Seems to be linked to the power of the machine, a dual core with 4gig RAM seems insufficient. What do you use? – pebwindkraft Jul 8 '17 at 6:18
  • I have an Intel i7-6700HQ cpu and 16gb of ram. Fairly sure it's quadcore, but not 100% sure – Reece Jocumsen Jul 8 '17 at 6:46
  • @Reece Jocumsen it is quad core indeed and it should be enough to power, are you mining with GPU or CPU ? – Rémi Jul 8 '17 at 8:52
  • I haven't started mining yet, all I did was type 'geth --rpc --fast --cache=1024' into cmd and let it run. I read the post I was linked to and decided to delete the files I'd already had and try again and see how that turns out. – Reece Jocumsen Jul 8 '17 at 11:01
0

First Check syncing progress by

$ geth attach
> eth.syncing
{
  currentBlock: 2272408,
  highestBlock: 2326493,
  knownStates: 0,
  pulledStates: 0,
  startingBlock: 2265791
}

With every time you run eth.syncing you should see number increased. Syncing would finish when currentBlock reach highestBlock.

Important issue

If you saw currentBlock isn't increasing anymore at last few hundreds remaining blocks, one of most important problems is your system time! Try to enable network time synchronisation on your computer and restart geth after that may solve your problem.

You can use following command to enable NTP on Ubuntu.

timedatectl set-ntp true

Not the answer you're looking for? Browse other questions tagged or ask your own question.