2

Well I tried to setup my first ethereum mining rig.

I bought 6 second hands rx480 8GB (some on eBay, some elsewhere..) And these new parts:

-Z170 gaming K3

-Powered pci risers

-8GB DDR4 Crucial

-2x RMi750W PSU

-Add2psu adapter

-60GB SSD corsair

Well, I made the set up (cards, risers powered by sata/molex), I put 3 cards by PSU, installed win 10 and started mining on claymore.

I get a 1200W power consumption, and a 145mh/s speed which is good for me. Well, it mined for 40min and I got a blue screen "thread stuck in device driver" ..

Well I said to myself, it perhaps about windows so I installed Ubuntu and amdgpu-pro.. Well, same thing, 6 cards detected but I get a watchdog error "GPU2 Hangs in OpenCL call" or "GPU4 Hangs in OpenCL call" the miner try to reload but I get a frozen screen again..

Today I tried some switch between risers and PCIE slots I got the same error on same card (I identified the card with a 100% fanspeed settings on claymore)..

I tried to remove completely the GPU2 so 5 gpu mining but i get the "GPU4 Hangs in OpenCL call" error when I try this.

It work good with 4 cards only (even if the gpu4 is one of the 4 cards used). So I don't understand.. Could it be a PSU problem ? Not enough power ? It was a little bit more stable on windows I think.

I must specify -> I didn't overclocked the cards. Any help appreciated :)

0

You could check if it's the power supply problem by using "aticonfig --odgc --odgt" command to see how much your GPUs are consuming.

Also, make sure you have the right BIOS settings on your motherboard. It could sometimes lead to an unstable rig setup. This video (https://www.youtube.com/watch?v=DR-FkpU2KfI&feature=youtu.be) helped me make my rig stable with 6 GPUs for an asus motherboard. Hope you find similar settings on the Gigabyte motherboard as well.

0

Try to install special drivers for mining "AMD blockchain driver" and before it you must delete your previous drivers using "AMD Clean Uninstall Utility"

0

1200 w on a 2x750 w is not ok in your rig. You should have at least 1800 w of nominal psu power to go stable. Simply remove cards up to be around 1000 w of consumption and test. If it does not crash anymore, your solution is there.

Btw: you should probably undervolt your cards: rx480 are able to consume a lot of power elsewhere!

As a basis be sure of mechanical fix of your riser on motherboard: do not rely on the electrical connector hold and beware of USB cables spring effect. Try to fix firmly your risers using nylon straps or plastic wire using some holes in the motherboard or whatever... this is very important.

On the other hand: how did you wire your PSUs? Did you balance electrical power between the two PSUs? Did you supply each riser with the same psu which feed the respective GPU?

BTW using SATA connectors for riser is generally deprecated because of high temperature in the interface. The most of fire events in the mining history have been from SATA used in risers, even if it is normal to find them in the riser box when you buy it!

And so on.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.