I created a paperwallet with myetherwallet a while ago. I tried to scan my private key with coinomi inorder to swipe the wallet, but I got an error: "There was a problem scanning: unsupported address"

my address looks as follows: (not an exact copy, but the + signs and the quanity of letters/digits are the same)


The address looks strange to me, as I thought it should be 64 letters and numbers. Is this an encrypted key? Is the key corrupt, or most likely do I have no clue what I'm doing???

Thanks for your help

  • That doesn't look like an address commonly used by ethereum, it looks like base 64, but can be anything. Are you sure that it was generated by MyEtherWallet?
    – Ismael
    Jul 6, 2017 at 5:00

2 Answers 2


It has the same length as an encrypted private key. Have you an password? Try it on the myetherwallet.com site


Check "Private Key"

  • 1
    please try to provide a better answer, or comment the question
    – Badr Bellaj
    Jul 6, 2017 at 9:26
  • I hope it solved the issue.
    – xgabrielx
    Jul 7, 2017 at 11:22
  • I have the same issue, how did you decrypt the key? ethaddress.org no longer exists.
    – Mike
    Oct 19, 2017 at 23:40
  • Mike, did you try the myetherwallet.com site? myetherwallet.com/#view-wallet-info
    – xgabrielx
    Oct 21, 2017 at 8:33

I have experienced the same thing: Paper ETHereum wallet causes error when sweeping private key into Coinomi. However - scanning same QR and pasting into myetherwallet.com works just fine. Here's a test. See for yourself. Please do NOT import the .$11 unless you absolutely need it to to fix this.

Ethereum paper wallet - generated by MyEtherWallet.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.