I'm trying to get started with Ethereum. So I tried the Ethereum wallet, but it took way too long, and after it finished I couldn't even mine on the test network. So instead, I tried to use GETH, and when I did geth --testnet --fast --cache=1024, it again takes a long time, and the testnet is now at processed=4629136. Is this too many blocks? Is the testnet really this large? I'm trying to get started with this but it's very confusing and there is basically no documentation for troubleshooting.


2 Answers 2


If you want to use the test net, there several ones. My favorite is Ropsten. But: --tesnet does not really work anymore in most cases, as this points to the old testnet that is not being use any more.

To access the new ropsten testnet, just run (its a very long command, you need to scroll right)

geth --testnet --fast --bootnodes "enode://20c9ad97c081d63397d7b685a412227a40e23c8bdc6688c6f37e97cfbc22d2b4d1db1510d8f61e6a8866ad7f0e17c02b14182d37ea7c3c8b9c2683aeb6b733a1@,enode://6ce05930c72abc632c58e2e4324f7c7ea478cec0ed4fa2528982cf34483094e9cbc9216e7aa349691242576d552a2a56aaeae426c5303ded677ce455ba1acd9d@"

or with parity

parity --chain ropsten --bootnodes "enode://20c9ad97c081d63397d7b685a412227a40e23c8bdc6688c6f37e97cfbc22d2b4d1db1510d8f61e6a8866ad7f0e17c02b14182d37ea7c3c8b9c2683aeb6b733a1@,enode://6ce05930c72abc632c58e2e4324f7c7ea478cec0ed4fa2528982cf34483094e9cbc9216e7aa349691242576d552a2a56aaeae426c5303ded677ce455ba1acd9d@"

Be patient...and soon you will be on the testnet.

You can check your sync status by comparing block numbers with https://ropsten.etherscan.io/


What you are saying could be due to congestion in ether network due to rash of ICO. This article can give some idea

Even when I logged in to coinbase account I get this message :

Ethereum Transaction Delays We're currently working through a backlog of Ethereum withdrawals. Recent or new outbound transactions may remain pending longer than expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.