2

I followed these instructions to install a geth node on an ubuntu vps. If I try a command via ssh it says geth: command not found. Do I need to be in a specific folder to run the commands?

2

If you've built from source, which I think your description (and link) implies, then your built binary won't have been automagically copied to the /usr/bin/ directory. In this case you'll need to run the geth command from the location specified in the instructions, which is /build/bin/geth.

If you want to be able to run geth from anywhere, you'll either need to:

  • Add the /build/bin/ directory to your $PATH,
  • Manually copy the built geth binary to /usr/bin/ (which is already part of your $PATH).

Alternatively you could install from the PPA and have all this done for you automatically. (This is what I would do, unless I wanted the very latest code.)

  • I still get the same error if I run it in the go-ethereum directory – Joe Jun 28 '17 at 13:14
  • 1
    Okay, I hadn't read the wiki properly :-) The very final instruction says you can run it from build/bin/geth, which is where the make step must put it instead of leaving it in go-ethereum. – Richard Horrocks Jun 28 '17 at 13:18
  • 1
    build/bin/geth is an executable file. running it starts the node. – Joe Jun 28 '17 at 13:37
  • Great, glad it worked :-) (That's what you were after, right?) – Richard Horrocks Jun 28 '17 at 13:40
  • I wanted to use the geth command line options so that I could run as a light client – Joe Jun 28 '17 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.