1

I run local Parity node on my Win 8.1 computer and was trying to check how RPC is Working But it is not working

I tried PostMan:

http://127.0.0.1:8445 Content-Type application/json Body {"method":"parity_accountsInfo","params":[],"id":1,"jsonrpc":"2.0"} Get answer: Could not get any response

I tried CURL( like Parity documentation said ):

curl --data '{"method":"eth_accounts","params":[],"id":1,"jsonrpc":"2.0"}' -H "Content-Type: application/json" -X POST localhost:8545 get answer error {"jsonrpc":"2.0":{"code": - 32700, message:"Parse error", "data":null}, "id": null}

What did I do wrong? Thank you Alex

  • Hi there. What options did you start Parity with? (Also, in your PostMan example, you've used 8445, not 8545. I think that's probably a typo in your question, rather than a typo in PostMan, as your CURL example uses the correct port and still fails. Thought I'd mention it anyway.) – Richard Horrocks Jun 28 '17 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.